Utility menu Top

Canon tester wanted

Error message

Deprecated function: The each() function is deprecated. This message will be suppressed on further calls in _menu_load_objects() (line 569 of /home/digicamc/public_html/oldsite/includes/menu.inc).
52 posts / 0 new
Last post
Duka Istvan
Canon tester wanted


I decided to use Canon SDK (versus MTP control) to control Canon EOS cameras, but i don't have any canon cameras so i need testers to test support for canon cameras.

The testing it is simple connect canon camera and post (or send email to admin [at] digicamcontrol [dot] com) your observation and the log file (Settings->locate log file) and some screen shot if you acured any visul error . Now i try to find if camera is regonizet (not the wia ones). 


In this thread i will post the latest test version :



Thanks for testing
Canon EOS

Hi Duka,
I can test on a Canon EOS 550D this Sunday.
I will also be testing on a Canon EOS 1100D in on Monday.


Duka Istvan


Please make sure to use the latest test version.



Canon EOS 400D

Hi Duka,
have tested the EOS 400D, 450D and 550D.

Unfortunately the cameras do not work with your software.
When using 'simple capture', 2 drivers show up in the drop down box. Both drivers have the same name (Canon EOS ***).

In all modes, (Simple, CMD and normal) the software connects to the software, but when i try to capture, the software returns an error message: "The method or operation is not implemented".

Attached is the log file

Duka Istvan
Thanks for testing but please

Thanks for testing but please use version 0.9.514 from first post.

I installed the new version

I installed the new version (0.9.514) and it works better.
I can take photos within the software, but unfortunately the CMD version does not work. When using '/capture' the shutter releases but then nothing happens, the photo isn't saved anywhere and the command line does not return. (EOS 400D, windows XP)

Duka Istvan
Pls. upload the log file,

Pls. upload the log file, maybe i figure out, what is the problem.

Thank you Duka,

Thank you Duka,
Attached is the log file.

Canon EOS 650D

Hi Duka, I tested with Canon 650D.
The software recognize it and can start the capture but then wait infinitely to download the image from camera.
I killed the process after 1 minute.
Attached you can find the log file.
Regards, AC.

Canon 60D

Very sorry to be so slow to respond.
I have now tried my 60D with version 0.9.514
It recognises the camera, and will open into LiveView and will Capture when required.
The Autofocus works (but not if Focus is set on camera to BackButton) and I think the Focus adjust controls seem to work ok.
With camera set to Shutter Priority (TV mode) I can change Shutter Speed as needed.
But everything else is totally blank with no options becoming visible and all remain completely unresponsive.
Please see attached screenshot.

Duka Istvan
You can make a another try

You can make a another try with latest relesed beta 0.9.516 ? If added iso and exposure compensation too.

Canon 60D

Duka, thank you.

Yes, your changes do work. (setup_v.1.0.0).

But in LiveView...
a) Is there no Zoom possible?
b) Also the small LiveView 'thumb' image flickers constantly and very badly (impossible to work with this flickering).
c) And...what is the small number beside that 'thumb' image? It changes to 4 or 7 or 8 for no apparent reason?

My regards, Glenn
(App log attached)

EOS 400D

have you tried http://www.microsoft.com/en-us/download/details.aspx?id=26829 . then DIGICAMCONTROL?

Using Version 1 I can take photos and auto-focus werks ..

Apature , White Balance, Compression, metering Mode dont werk

Duka Istvan
Please upload the log file

Please upload the log file too.

Thanks for testing

Canon EOS 400D Log

I hope this is what u want

Canon EOS 7d

I can test Canon EOS 7D
I will try to run the test today evening and let you know the results

Duka Istvan


Here is my results

Hi Duka,
Following options are not available (the drop down lists are empty): Compression, Metering Mode, Focus Mode and White Balance.
Download Photos window shows no photos despite I have few on my CF card.
Other thing seems to work good, I can focus and capture photo in regular and in Live mode (however, "Start Record Movie" is disabled there, I don't know if it should work or not) and change other settings such as ISO, Aperture, Shutter speed and Exp. compensation.

See attached my log file (I will see some strange error in the beginning of log file, that is because I had some problem with USB port, then I connected it to another port and it start working)

P.S.: If you interested I can help you in development

Duka Istvan
Hi tanks for reporting, there

Hi tanks for reporting, there a lot to improve in canon part... Yes i'm interested, if you really like to help in development please contact me,  there is a lack of developers with canon cameras :) 

Canon EOS 5D Mk II

Just downloaded v. - Using Win 7 Home Premium SP#1
Log file attached
I can get the program to correctly identify the camera. And can take a picture via DigiCam--however, as soon as the picture shows up in digicam, the program shuts down (I get the Windows box that says it is looking for a solution). If I restart the program, it immediately quits. The only way I can get DigiCam to restart and stay active is to use another program to delete the downloaded image file.

Duka Istvan
Thanks for testing i will try

Thanks for testing i will try to fix this bugs for next version.

5D Mk II

I'll watch for it.

Looks like this is a great program.

550 and 600

Hi, i can test for you on canon 550 and 600 ...
Just need to be notified when test is required ...
Already for version 1.0 i can report, that in live view i am not able to zoom in the view window and also the zooming square is not appearing ...

Canon EOS 350D

Canon EOS 350D

Apparently Nothing Works

again, 350d

confirmed, 350d doesnt work, but digicamcontrol detect it.
And when the camera off (auto-off), the digicamcontrol also closed abruptly.

Duka Istvan
Thanks for log file

Thanks for log file

EOS 400D

Tested further and found that "Bulb" doesn't work ... would be a great feature if it did as 30 seconds isnt enough :)

Duka Istvan
It is planed just need to be

It is planed just need to be fixed

EON 400D

thanx ... an addition to an already awesome program ;)

5D Mark III

The program is able to:
- recognize my 5D Mark III
- capture photo from the program and download it from camera
- download a photo from the camera when it is taken by camera
- tune aperture/shutter speed/Iso from the program and these settings are applied to camera.
- tune aperture/shutter speed/Iso from the camera and these settings are reflected in the program as well.

Duka Istvan
Thanks for report 

Thanks for report 

EOS 550D - Autofocus broken

So i was able to use the latest version with my 550D.
LiveView focusing worked and was able to capture some pics and send to PC.
When trying the focus-stacking, the program suddenly froze and shut down.
Now with the camera disconnected from the PC, i cannot Auto-focus anymore, Unfortunately i cannot comment if the lens is damaged or the body, since i currently only have a Kit-Lens. I will take the cam to a shop on Monday to try out a different lens.

report attached.

Duka Istvan
Hi i don't think your camera

Hi i don't think your camera or lens is damaged. Please check focus settings in your camera theoretically it is in manual.

EOS 550D - Autofocus broken - RESOLVED

I fixed the problem.
I reset all Camera settings, including all Custom Func. Then removed the Battery.
The removal of the Battery seems to be important, since just clearing the settings did nothing.

All good now.

beta 10608

i just tested the new beta with Canon 600D ... seems to work fine except the live view ... any zoom % setting (from the rdopdown list) does strictly NOTHING ...
Even the focus rectangle does not appear ...

EOS 5D Mk III, 6D, 40D

I have tested the EOS 5D Mk III, EOS 6D and EOS 40D with varying levels of success.

Control: Yes
Live View: Yes
Capture: Yes
Auto Focus: No (see log file 40D_AutoFocusFail_StopLVFail.txt)
Download: No (see log file 40D_ErrorLoadingFileList.txt)

The program would not even initialize this camera. Log file 6D_Failure.txt

5D Mk III:
Control: Yes, though sometimes the Aperture setting had some bad/missing value (i.e. 1, 3,2, 64, etc.)
Live View: Yes
Capture: Yes, but capture during live view froze the program (see log file 5DMKIII_CaptureDuringLV_RawFileError.txt)
Auto Focus: Yes
Download: Yes after capture, but the download files window fails (see log file 5DMKIII_ErrorLoadingFileList.txt)

Also, I had some issues with the raw files from the 5D when they were captured. The program would not load them, 5DMKIII_CaptureDuringLV_RawFileError.txt seems to indicate the Canon raw file format is not supported.

Nikon D40x

Tested my Nikon D40x and it works in all features allowed by camera.

Duka Istvan
Thanks for reporting, camera

Thanks for reporting, camera description updated

I demonstrated Digicam to the

I demonstrated Digicam to the members of a camera club of which I ama member here in France. The canon users will be sending their findings via me as they cannot write in English.  So far one member found she by downloading Microsoft camera codec it works perfectly and another with a 7D.  as I get more info I will let you know.  We will also be sending a donation

Duka Istvan
Thanks for help. I'm waiting

Thanks for help. I'm waiting any improvement suggestion too. 

EOS 650D test

I used the Canon EOS 650D with digicamcontrol 1.1.795 (Beta), without checking the compatibility list beforehand. Here is the result:

  • Camera can connect to digicamcontrol
  • It is possible to take photos remotely with the button in the top left corner
  • It is possible to engange the LiveView screen and see the LV image in digicamcontrol
  • It is possible to start time lapse capturing, although it does not work reliably


  • Time lapse capturing may crash after a few images. I had two time lapses running for over 1 hour (>100 images) during dawn and in Av mode, but two others during night in M (10s shutter speed, 2s shutter delay, image every 14s) mode crashed after ~10 images by showing the "Are you sure you want to quit the timelapse movie?" dialog. Independent from the users answer they would then ask for a crash report to be sent.
    (Where on the HDD are these crash reports stored anyway? Would like to have a look into them for the reason.)
  • Changing camera parameters doesn't work correctly. Changing camera parameters like ISO in digicamcontrol may have no effect at all or it has a completely unexpected result.
    For example. I had a time lapse running in Av mode in dusk but decided I wanted to increase ISO in order to not get exposure times > 8s. I stopped the time lapse, quickly changed from ISO400 to ISO800 and re-started the time lapse.
    Expected result: ISO set to 800 and half the exposure time.
    Actual result: Camera still showed ISO400 (digicam showed ISO800) but exposures dropped from 8s to 3s, resulting in far darker images.
    I experienced a few quirks like this.
  • digicamcontrol cannot do shots if camera is in normal drive mode and mirror lock-up is enabled. In this mode the camera needs two button presses: The first locks the miror, the seconds starts the exposure. digicamcontrol doesn't handle this. So currently when mirror lock-up is enable, it is required to use 2s delay drive mode, which requires only one trigger event.

Not tested:

  • Explicit image downloading
  • Exposure bracketing

Hope this helps.

P.S. digicamcontrol 1.1.0 was absolutely unusable for EOS650D (would hang after each shot) in contrast to the above version 1.1.795.

Duka Istvan
The log file can be found by

The log file can be found by opening the Settings window. There you will find the button for "Locate log file". After pressing this button a Windows Explorer window will open and the log file will be selected. Please post that log file. 

Testing Canon 100D

On my Canon 100D with stock 18-55 lens, runnning on AC, and a remote trigger:


Using 1.1.796 and 1.1.794 the extra settings page doesn't pop out like it does for my nikon cameras, the basic settings show, but when you click on the greater then sign in the circly, just a small grey narrow box appears, rather then all the normal options.. 


ISO is not functioning properly, unless you physcially go thru the camera to set the iso, you can't change it. The ISO is blanked out all the time on the software, even if you've physically changed it on the camera off of auto, it's still blanked out in the software. If the camera is on AUTO iso, the iso does change automatically.


Everything else seems to work fine on the 100D.


Also in live view there is alos a control tab, and this one also has the colapsible second part, but it's not working either.

Missing menu

Any word on the missing menu Duka?

Duka Istvan
That menu not missing just

That menu not missing just isn't implemented yet. Now i working on a rework of live view window, after that i will fix this issue and other reported by you.

You can check the progress using this link: https://github.com/dukus/digiCamControl/issues/17

Many thanks Duka, we've just

Many thanks Duka, we've just place orders for 10 100D's so looking forward to hooking them all up to your software shortly!

Log files for EOS 650D

As requested, here come the log files for the post from June 21st with the EOS 650D.


Duka Istvan


angelos siskos
eos 40 d

i just test it on CANON EOS 40D  and the result are:

the program recognize the camera but...

1.the host mode doesn't work .....i can't  change the M,Av,Tv,P .is grey out....

2.when i change the shutter  ,on Tv mode, the aparture stays the same

3.when i change the aparture ,on Av mode ,the shutter speed stays the same

is like i have it on a M mode ......

.............so it works properly only on M mode.

4.the white balance is working ok

5.the metering i can't test it cause there is the (#2 and #3 problems)

6.sometimes when i open another  program  infront of the Digicameracontrol on windows 7 ,and i press the space button, the camera shoots by itself !!!!??? 

but it's ok :)

7.the iso works ok.

all these are tested without Live View


in Live View ,and my lense in autofocus ,the focus arrows  buttons works ok , but when i press the "capture" it does nothing. :(

the program is like freezes and it can't close the Live view..so i have to exit the program and open it again.

but if you focus using the arrows  in Live view mode and then exit from Live view  ,set your lense to M mode and press the capture button on the left top corner ...it works...   It,s not the best way but it works.

btw , it's a very good program .







Duka Istvan
Please upload your log file. 

Please upload your log file. 

angelos siskos
LOG FILE for my Canon 40d

ok ..i found it